Back to overview
Degraded

Motor is experiencing issues with the HD labor data.

Jan 18 at 11:34am PST
Affected services
Application

Resolved
Jan 19 at 12:01pm PST

Motor has resolved this issue on their end.

Updated
Jan 19 at 08:25am PST

Motor is still working towards full resolution. Heavy duty data lookup is starting to work again. Motor still engaged.

Created
Jan 18 at 11:34am PST

Motor is experiencing an issue with heavy duty labor queries.

Motor is working to resolve this issue on their end as soon as possible.