Back to overview
Downtime
Slow Performance
Dec 07 at 10:21am PST
Resolved
Dec 07 at 10:57am PST
We have identified and implemented a fix for the issues, and are monitoring the resolution.
Affected services
Updated
Dec 07 at 10:35am PST
The application is currently down. We are continuing to investigate the issue and are working on a fix.
Affected services
Created
Dec 07 at 10:21am PST
We are currently investigating slow performance and load times, which has affected multiple services.
Affected services