Get in touch
Back
Resolved

Fix has been rolled out to production and we are monitoring

Started 13 Oct at 11:27am PDT.

API
Created

We identified the issue and have rolled out a fix. We will continue monitoring to ensure online payments are processing as expected.

Posted 13 Oct at 11:27am PDT.