Get in touch
Back
Maintenance

Backend database upgrade

Completed 28 May at 11:30pm PDT.

Application API Mobile
Completed

Posted 28 May at 11:30pm PDT.
Started

Our backend database is scheduled to be upgraded. There is no downtime or service degradation expected from this activity.

Posted 28 May at 11:00pm PDT.