Get in touch
Back
Degraded

Slow Performance

Started 25 Aug at 10:10am PDT, resolved 25 Aug at 10:46am PDT.

Application API Mobile
Resolved

We have identified and implemented a fix for the degraded performance issues, and are monitoring the resolution.

Posted 25 Aug at 10:46am PDT.
Created

We are currently investigating slow performance and load times, which has affected multiple services.

Posted 25 Aug at 10:10am PDT.