Get in touch
Back
Degraded

Slow performance

Started 11 Aug at 10:29am PDT, resolved 11 Aug at 11:15am PDT.

Application API Mobile
Resolved

We have identified and implemented a fix for the degraded performance issues, and are monitoring the resolution.

Posted 11 Aug at 11:15am PDT.
Created

We are currently investigating slow performance and load times, which has affected multiple services.

Posted 11 Aug at 10:29am PDT.